H Apple επιδιορθώνει το κενο ασφαλείας FREAK με αναβαθμίσεις για iOS, Mac

freakΕρευνητές αποκάλυψαν πρόσφατα κενό ασφαλείας που ακούει στο όνομα ‘Factoring attack on RSA-EXPORT Key’ (εν συντομία ‘FREAK’), χρονολογείται από το 1990 και θέτει σε κίνδυνο Mac και iOS συσκευές κατά την επίσκεψη ασφαλών ιστοσελίδων από το Safari.

Το «Freak» έκανε την εμφάνιση του όταν κατά τη δεκαετία του ’90 η κυβέρνηση των ΗΠΑ ζήτησε από τις εταιρείες μέσω νομοθεσίας  να χρησιμοποιούν πιο αδύναμη 512-bit κρυπτογράφηση για να εξυπηρετούν τους πελάτες του εξωτερικού, με αποτέλεσμα εκατομμύρια χρήστες να είναι έκτοτε εκτεθειμένοι σε υποκλοπές και κυβερνοεπιθέσεις.

Λίγες μέρες αφότου έγινε γνωστό το σοβαρότατο κενό ασφαλείας, η Apple ανέλαβε δράση προβαίνοντας σε αναβαθμίσεις για όλες τις πλατφόρμες της: Apple TV 7.1 για το Apple TV 3ης γενιάς, iOS 8.2 για iPhone 4S, iPod Touch 5ης γενιάς, iPad 2 και νεότερες εκδόσεις, Mountain Lion 10.8.5, Mavericks 10.9.5 και Yosemite 10.10.2.

[via]